Index du Forum » » La machine à café

Auteur

Bug mondial certificat de sécurité HTTPS
JM-C
 11436  
     

  Posté : 30-09-2021 22:22

Pour ceux qui ne le savent pas, depuis 16:01, les connexions HTTPS sont refusées par les versions trop anciennes des navigateurs ET des systèmes d'exploitation.

Il est par exemple impossible d'accéder au site Tecelyon avec le navigateur Chrome sous Windows XP qui renvoie un message d'erreur (d'ailleurs erroné)

ERR_CERT_DATE_INVALID

En effet un certificat de sécurité majeur « Identrust DST Root CA X3 » a expiré cet après-midi et n'a pas été mis à jour (volontairement ?). Il a été remplacé en 2017 par un autre appelé "ISRG Root X1" qui n'a pas été installé sur les OS et navigateurs qui n'avaient plus de mise à jour.

Citation: https://letsencrypt.org

Platforms that trust ISRG Root X1
 
  • Windows >= XP SP3 (assuming Automatic Root Certificate Update isn’t manually disabled)
  • macOS >= 10.12.1
  • iOS >= 10 (iOS 9 does not !!include!! it)
  • iPhone 5 and above can upgrade to iOS 10 and can thus trust ISRG Root X1
  • Android >= 7.1.1 (but Android >= 2.3.6 will work by default due to our special cross-sign)
  • Mozilla Firefox >= 50.0
  • Ubuntu >= xenial / 16.04 (with updates applied)
  • Debian >= jessie / 8 (with updates applied)

  • Sous Windows XP, ça ne fonctionne seulement qu'avec Firefox >= 50.0 (la dernière est 52.9 ESR) et si le SP3 (qui date quand même de 2008) a été installé.



    Cet article provient de Tecelyon

    https://www.tecelyon.info//viewtopic.php?topic=1597&forum=11